package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)$.`)
var str = `next line is a blank line
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}