re = /^(?U)(.*(?:[aeiouyäöü])(?:[^aeiouyäöü]))(?X)(.*)$/
str = 'umweltfreundlich'
# Print the match result
str.match(re) do |match|
puts match.to_s
end