const regex = /(?s)\<A\>.*?\<\/A\>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\<A\\>.*?\\<\\\/A\\>', 'gm')
const str = ` <A>
<name>ns1</name>
<ORIGIN>example.com</ORIGIN>
<class>IN</class>
<host>127.0.0.1</host>
<ttl>172800</ttl>
</A>
<A>
<name>ns2</name>
<ORIGIN>example.com</ORIGIN>
<class>IN</class>
<host>127.0.0.2</host>
<ttl>172800</ttl>
</A>
<NS>
<name>example</name>
<ORIGIN>com</ORIGIN>
<class>IN</class>
<host>ns.example.COM</host>
<ttl>172800</ttl>
</NS>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}