$re = '/(^[^@]+(?:\n|$))/m';
$str = 'test@flamp.ru
yandex.ru yandex.ua
ewkljlkewr
1@1.com
self
blob: data: yandex.ru yandex.com
self';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);