$re = '/(?i)(?<![a-z]{2})[a-z]\./m';
$str = 'This is Dr. Mathurs cabin.
Yes it is.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);