$re = '/((XYZ|xyz|Xyz|Convent){1}(\s{0,})(INTERNATIONAL|International|international|INC|Inc|inc|LLC|Llc|llc|WORLDWIDE PTE\. LTD\.){0,})([\r\n]|[\t]|[ ]{2,})(?<CircuitID>[a-zA-Z0-9\-\/\ ]{6,26})\s*/m';
$str = 'Circuits Affected:
Company Name Circuit ID Z End Billing ID ServiceType
XYZ INTERNATIONAL A1B101012 ABCD-XYZ-ABG089AB A000123456 UNI
XYZ INTERNATIONAL AB/PQRS/012345/ /ABC / PQRSTUVW ABCDEFGH CO ADDRESS CITY 1234 S RIDGELINE BLVD VA SOMECITY 12345 SOME BRANCH PKWY A0123456 N/A 0:00 CDT - 1:00 CDT
________________________________________
XYZ INTERNATIONAL AB/ABYX/271703/ /ABC / ABCDO47HBS ABCDEFG71 N/A N/A A0123456 N/A 0:00 CDT - 1:00 CDT
________________________________________
XYZ WORLDWIDE PTE. LTD. A1234597 N/A N/A N/A N/A A0123456 abcde-randomashb-12234568 0:00 CDT - 1:00 CDT
________________________________________
Convent Inc A1234599 N/A N/A N/A N/A A0123456 abcde-randomhigh-00012345 0:00 CDT - 1:00 CDT
________________________________________
XYZ INTERNATIONAL B124565 N/A N/A N/A N/A A0123456 abcde-randomashb-12234568 0:00 CDT - 1:00 CDT
________________________________________
XYZ INC WA/OGGS/186815/ /ABC / ABCDEFGH PQRSTUVW N/A N/A A0123456 N/A 0:00 CDT - 1:00 CDT
________________________________________
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);