import re
regex = re.compile(r"(?<timestamp>\d\d\d\d-\d\d-\d\dT\d\d:\d\d:\d\d.\d\d\dZ)\s+(?<level>INFO|WARN|DEBUG|ERROR|FATAL|TRACE)\s+(?<text>.*?\s.*?)\-\s+\-\s\[(?<class>.*?)\]\s+(?<Message>.*? |\Z)", flags=re.DOTALL)
test_str = ("2019-11-14T04:24:04.072Z INFO MessagingObjectFactoryImpl-4-2 ExporterLastAckServiceImpl - - [nsx@6876 comp=\"nsx-manager\" level=\"INFO\" subcomp=\"manager\"] Found exporter with elaId = Node#a3844284-e626-11e9-a87b-005056bcc0c6#AggSvc-L2-Bridging, returning lastAck = 16507 \n"
"2019-11-14T04:23:08.362Z INFO ActivityEventRecovery-1 ActivityCacheManager - - [nsx@6876 comp=\"nsx-manager\" level=\"INFO\" subcomp=\"manager\"] Handling activity 92d6a146-fa12-4889-a0ff-441087e047d0 completion event for 1 \n"
"2019-11-14T04:23:08.362Z DEBUG ActivityEventRecovery-1 ActivityCacheManager - - [nsx@6876 comp=\"nsx-manager\" level=\"INFO\" subcomp=\"manager\"] Handling activity 92d6a146-fa12-4889-a0ff-441087e047d0 completion event for 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")