$re = '/-?0+(\.0+)?([eE][+-]\d+)?/m';
$str = '0.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);