const regex = /<script>.*(adsConfig).*<\/script>/sm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script>.*(adsConfig).*<\\\/script>', 'sm')
const str = `<script>
var middleCount = 0;
var adsConfig = {
nonLinear: {
url: "https://8245.digital/vpaid/?id=7875&type=nonlinear&dcc=1",
total: 0 ,
offset: 10 * 60,
label: { name: 'label', val: 'overlay', counter: true }
},
pre: {
maxImpressions: 2 ,
urls: ["https://8245.digital/vpaid/?id=5241&label=preroll&dcc=1&maximp=2&synconly=1"]
},
middle: {
pop: true,
maxTotalImp: 0 ,
maxImpressions: 1,
urls: ["https://8245.digital/vpaid/?id=21515&synconly=1&maximp=1&dcc=1&mid=6","https://8245.digital/vpaid/?id=5242&synconly=1&maximp=1&dcc=1&mid=6"]
,
getUrls: function () {
var u = middleCount && adsConfig.middle.urls
? adsConfig.middle.urls.slice(1)
: adsConfig.middle.urls;
middleCount++;
return u;
},
label: { name: 'label', val: 'middleroll', counter: true }
},
confirmTimeout: 60 * 1000,
confirmOn: ['localhost', 'zombie-film.net'],
vast: {timeouts: {loading: 20000, starting: 20000, global: 120000}},
volume: 0.3,
tv: true,
suppressOnFakeFullScreen: true
};
</script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}