$re = '/\S*\d+\S*/m';
$str = 'Добрый лень! Подскажите пожалуйста какой задать паттерн регулярного выражения, что бы из строки достать все номера, даты и прочие части которые содержат цифры? Например есть такая строка "Перенос остатков денежных средств с л/с 05564П56000 на л/с 05564Ф56010 сложившихся по состоянию на 01.01.2023г. на основании письма от 27.12.2022г. №НП-03-24/32768" и нужно из неё вытащить, то что выделено жирным. Заранее спасибо!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);