re = /(["'`])((?:\\.|(?!\1|\\).)*)(\1)/m
str = '\'\\\'jk\\\'"
\'\\\'jk\\\'"\'
\'\\\'jk\\\'"\'
\'\\\'jk\\\'"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end