re = /^(?!666|000|9\d{2})\d{3}[- ]{0,1}(?!00)\d{2}[- ]{0,1}(?!0{4})\d{4}$/
str = '012-12-0928'
# Print the match result
str.match(re) do |match|
puts match.to_s
end