#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\b(\w+[<?\w+>?]*\s)(\w+)\b((\s{[get;\|private get;|set;]+)|\(.*\));)"
Local $sString = "void Something();" & @CRLF & _
"int SomethingElse(Parameter parameter);" & @CRLF & _
"List<Something> SomethingVeryElse(One one, Two two);" & @CRLF & _
"IEnumerable<Plugin> Plugins { get; }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")