$re = '/(?![^\d]+)[^,]+/m';
$str = '\'Anakinra 100 g, gentechnologisch hergestellt aus E. coli.\'
\'Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.\'
\'Anakinra 10.5 g, gentechnologisch hergestellt aus E. coli.\'
\'Anakinra 10, gentechnologisch hergestellt aus E. coli.\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);