#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?!.*\(.*\)).*?\)"
Local $sString = ""bar - (cocktails) - (drunk) - asdf - (dsafa - ifkt - (toekf) - ) - ("
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")