$re = '/(\w+|".*?")/';
$str = ' GRID "GLOBAL" LABEL "A" DIR "X" COORD 0 GRIDTYPE " "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);