import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^,]+)|(\\\"[^\\\"]+\\\")";
final String string = "79.151.89.210 - - [08/Oct/2018:21:59:59 +0200] \"GET /web/smartphone/scripts/onlineBanka-nt.min.js?v=20180912 HTTP/1.1\" 200 122582 \"-\" \"Mozilla/5.0 (Linux; Android 5.1.1; LG-H955 Build/LMY47S; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/69.0.3497.100 Mobile Safari/537.36|2|KBM_NATIVO|020302\" \"-\" 15600 0 - - \"FA66A7B9D443B2C4111E8F8E36DA44AD.worker37\"\n\n\n\n\n\n"
+ "ce.73989.48.kbgesdek.8523952889_EX-00028_0760831.PDF\n"
+ "ce.74106.48.kbgesdek.8527118018_EX-00028_0729298.pdf\n"
+ "ce.74844.48.kbgesdek.8527191264_EX-00028_0728038.pdf\n"
+ "ce.74844.48.kbgesdek.8527191264_EX-00028.pdf\n\n"
+ "#^ce[.]([0-9]+)[.]([0-9]+)[.]([^.]+)[.](.*)\n"
+ "#^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]*[.](.*pdf)\n"
+ "^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]([0-9]{10}_EX-[0-9]{5}_[0-9]{7})[.](pdf)\n"
+ "^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]([0-9]{10}_EX-[0-9]{5}_[0-9]{7})[.]([pP][dD][fF])\n"
+ "^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]([0-9]{10}_EX-[0-9]{1,5}_[0-9]{1,7})[.]([pP][dD][fF])\n"
+ "https://regex101.com/r/XX6Jra/5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}