$re = '/\b([0])\b/';
$str = '0 123050 0 0 12506 0 00 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);