package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b0\b`)
var str = `0 123050 0 0 12506 0 00 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}