const regex = /^\[[^\]]+\]\s+\[(?<firstfieldname>[^\]]+)\]\s+\[(?<secondfieldname>[^\]]+)\]\s+\[(?<thirdfieldname>[^\]]+)\]\s+\[(?<fourthfieldname>[^\]]+)\]\s+\[(?<username>[^\]]+)\]\s+(?<message>.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^\\]]+\\]\\s+\\[(?<firstfieldname>[^\\]]+)\\]\\s+\\[(?<secondfieldname>[^\\]]+)\\]\\s+\\[(?<thirdfieldname>[^\\]]+)\\]\\s+\\[(?<fourthfieldname>[^\\]]+)\\]\\s+\\[(?<username>[^\\]]+)\\]\\s+(?<message>.+)', 'gm')
const str = `[2020-03-29 18:37:51,020] [IG Audit Writer] [INFO ] [IG.AUDIT] [AUD6012] [UserNameHere] EventMessageHere`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}