package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:(?:\s*(?:to|[\n|;,])\s*)\d+)*$`)
var str = `1 to 9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}