$re = '/(?<!\w)(float|int|string)[ \t]*\((\w+)\) /m';
$str = '
int(x)
';
$subst = "\($1\)$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;