$re = '/(?<!\\\\)\'(.+?)(?<!\\\\)\'|(?<!\\\\)"(.+?)(?<!\\\\)"|(.+?)(?=\'|"|$)/m';
$str = 'Telling myself \'you are \\\'great\\\' \' and then saying "thank you" feels "a \\"little\\" nice"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);