re = /\.(?=[^.]*\.)/m
str = 'adsdasd.sdfdsfsdf.f43fvev.ASCSDF.sfgsdfssdf.yaml'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result