$re = '/<a data-id="\K.*?(?=")/';
$str = '<a data-id="777777"></a><a data-id="888888"></a><a data-id="99999"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);