$re = '/^([a-zA-Z0-9]*-[a-zA-Z0-9]*){2}$/m';
$str = 'cartsd-6dfdcd59f8-96cdb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);