re = /(?<=\[)i(?=])/m
str = 'val stringWithoutIndex = "object[i].base.base_x[i]"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end