const regex = new RegExp('(?<!\\.)[-+]?\\b\\d+\\.\\d+(?!\\.)\\b', 'gm')
const str = `Test string 1.234 0.155.1 5.67799350,-2.654657`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}