re = /\([^)]+\d{4}\)|(\S.*?)(?=\s*(?:\([^)]+\d{4}\)|$))/m
str = 'Text text text (Hung et al., 2020; Sung et al., 2021) text text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end