re = /(?:[12]\d|3[01]|\d)/m
str = '0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end