re = /https?:\/\/(?:(?!https?:\/\/)\S)*?\.com/m
str = 'jssbhshhahttps://www.one.comsbshhshshttp://www.another.comhehsbwkwkwjhttp://www.again.co.uksbsbs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end