$re = '/^[^(]+\([^()]+\)\K\([^()]+\)/m';
$str = '3D Combat Zone (1983)(Aackosoft)(NL)(en)[re-release]
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;