using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(R[0-9][0-9][0-9][0-9][0-9](?=\w+$))";
string input = @"Text R77777 R120943 R11114_8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}