$re = '~^(0(?1)?1)$~m';
$str = '01
0011
000111
00001111
0000011111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);