$re = '/(?m)^(?!\d*(\d)\1{4})\d{10}$/';
$str = '1234567890
1213141516
1111234567
1233333456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);