const regex = new RegExp('[^@]{2,64}@[^.]{2,253}\\.[0-9a-z-.]{2,63}', '')
const str = `name@anywhere.something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}