$re = '/(?<=(.*\d(?:\.|$)))/m';
$str = '1.2.5.6.8.10.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);