import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A # Begin at the beginning only! (No doing it again)\n"
+ " (?: # Non-capturing group consuming the string\n"
+ " (?| # Branch reset on two groups: p2 and p3 (p for prefix)\n"
+ " . # Consume a character\n"
+ " (?=.*+\\n(?<p2>\\k<p2>?+.) # Lookahead: Go to next line. Then add a character to a group\n"
+ " .*+\\n(?<p3>\\k<p3>?+.)) # Same. Will fail if the line is too short.\n"
+ " | # When the first brach fails:\n"
+ " .*+\\n(?<p2>)(?<p3>) # Consume the rest of the string. Reset the groups.\n"
+ " )+? # As little as possible (Only one character at a time)\n"
+ " (?<=X)(?=.*\\n\\k<p2>(?<=X).*\\n\\k<p3>(?<=X)) # Check to see if there's a column of X's\n"
+ " (?=[\\s\\S]*(?<count>[\\s\\S](?(<count>)\\k<count>))) # Add a character to a count group at the end.\n"
+ " )+ # Keep doing it until all is consumed";
final String string = "XX\n"
+ "XX\n"
+ "XX\n"
+ "X\n"
+ "X\n"
+ "X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}