const regex = new RegExp('(\\d+)\\|(ROOT)\\s*\\|(\\d+)(?=\\|)', 'gm')
const str = `000000002|ROOT |237277309|000000003|ROOT |337277309|000000004|ROOT |437277309|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}