import re
regex = re.compile(r"([\.!])([\"| A-Z])", flags=re.MULTILINE)
test_str = ("Twee biljoen driehonderdvierentwintig miljard tweehonderdtweeënvijftig miljoen tachtigduizend honderdtien pond. Dat was het bedrag dat een Brit aantrof op een compensatiecheque van het elektriciteitsbedrijf. \"Ik had meteen door dat het geen realistisch bedrag was.\"\n\n"
"Gareth Hughes had recht op een vergoeding omdat in november zijn stroom drie dagen was uitgevallen door de storm Arwen. Enkele tienduizenden Britten worden daarvoor gecompenseerd en bij 74 mensen ging dat fout, laat Northern Powergrid weten.\n\n"
"Met een tweet bracht Hughes het bedrijf op de hoogte van de fout. \"Voordat ik dit ga innen, weten jullie absoluut zeker dat jullie dit kunnen betalen?\", grapte hij. De 2,3 biljoen is twee keer de omvang van de gehele Nederlandse economie.\n\n"
"Het bericht werd duizenden keren geretweet. Sommige volgers raadden Hughes aan het gewoon te proberen. \"Innen! En dan eerlijk onder ons verdelen\", schreef iemand. \"Ik denk dat je nu eigenaar bent van Northern Powergrid\", lachte een ander.\n\n"
"Ook bij Danielle Henderson ging het fout. Zij trof 1.580.000.956.104 pond aan op de cheque. \"We moesten er om lachen. Het is de ene miskleun na de andere sinds de stroom uitviel.\"\n\n"
"Een woordvoerder van Northern Powergrid laat weten dat het om een administratieve fout gaat: bij deze mensen is de meterstand per ongeluk als het compensatiebedrag opgevoerd. De cheques zijn inmiddels ongeldig verklaard en vandaag krijgen alle klanten de juiste vergoeding in de bus.\n\n"
"Hughes denkt met een glimlach terug aan het moment dat hij virtueel twee keer rijker was dan Jeff Bezos, Elon Musk, Mark Zuckerberg en de hele rest van Forbes Top-10 bij elkaar. \"Ik wist dat ze niet zouden uitbetalen, maar het was fijn een paar minuten te kunnen dromen.\"")
subst = "\\1\\2\\n"
result = regex.sub(subst, test_str)
if result:
print(result)