import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^([^\\r\\n]+)\\s*\\n([^\\r\\n]+)\\s*\\n([^\\r\\n]+):\\s*([^\\r\\n]+)\\s*\\n([^\\r\\n]+):\\s*([^\\r\\n]+)(?:\\s*\\n([^\\r\\n]+):\\s*([^\\r\\n]+))?\\s*\\nDirections:\\s*\\n((?:.+\\s*\\n?)+?)(?=^[^\\r\\n]+\\s*\\n[^\\r\\n]+\\s*\\n[^\\r\\n]+:|\\z)";
final String string = "Bob's Diner\n"
+ "Reefer\n"
+ "Location: Mike's Beef Barn\n"
+ "Time: 1,584\n"
+ "Stop: Highway Hotel.\n"
+ "Directions:\n"
+ "Go south on Broadway.\n"
+ "Get on freeway 30 South. Exit Main St.\n"
+ "Go south on Main to Highway Hotel.\n"
+ "Go north on Main. Go east on Highway 15. Exit Market St.\n"
+ "1522 Market St.\n"
+ "Comfy Pillows and Mattresses\n"
+ "Dry Van\n"
+ "Location: Innovative Furniture\n"
+ "Time: 223\n"
+ "Directions:\n"
+ "Turn right and go to Seville Ave.\n"
+ "Turn left on St. Michael St.\n"
+ "Go to end at the Comfy Sign.\n"
+ "Washington County Construction\n"
+ "Low Boy\n"
+ "Location: Marble Quarry in Gainesville.\n"
+ "Time: 1,135\n"
+ "Stop: Mountainside Motel.\n"
+ "Directions:\n"
+ "Make a U-turn on Alameda Ave. and a right on Chantilly Lane.\n"
+ "Get on freeway 67 East.\n"
+ "Pass the Hospital and Exit Seward St.\n"
+ "Turn left on Coral St. to Mountainside Motel on right.\n"
+ "Exit motel and go east on Jefferson and then right on Belhaven.\n"
+ "Follow Joelle Ln. to Hwy 49.\n"
+ "Turn right at the Red Hill Junction. Go east on Harewood Rd.\n"
+ "Turn left on Blue Heron St.\n"
+ "8964 Red Rooster St.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}