$re = '/^@\d.*distribute_event: message EventRinging(?:\R(?!\d).*)*\R.*RTargetObjectSelected\'\h+\'\?VAG_EMERGENCIA2.*/m';
$str = '@20:20:51.8200 [0] 8.1.104.23 distribute_event: message EventRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA2:\'
20:20:53.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:20:54.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:20:54.821 Int 04544 Interaction message "EventRinging" generated
@20:21:51.8200 [0] 8.1.104.23 distribute_event: message EventRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA1:\'
20:20:54.821 Int 04544 Interaction message "EventRinging" generated
@20:21:51.8200 [0] 8.1.104.23 distribute_event: message EventRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_AGENCIA1:\'
20:20:54.821 Int 04544 Interaction message "EventRinging" generated
20:23:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:24:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
@20:25:51.8200 [0] 8.1.104.23 distribute_event: message EventRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA1:\'
20:20:54.821 Int 04544 Interaction message "EventRinging" generated
20:28:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
@20:29:51.8200 [0] 8.1.104.23 distribute_event: message EventNotRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA2:\'
20:20:54.821 Int 04544 Interaction message "EventNotRinging" generated
20:30:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:31:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:32:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
@20:33:51.8200 [0] 8.1.104.23 distribute_event: message EventRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA2:\'
20:20:54.821 Int 04544 Interaction message "EventRinging" generated
20:34:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:35:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:36:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
@20:37:51.8200 [0] 8.1.104.23 distribute_event: message EventNotRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA1:\'
20:20:54.821 Int 04544 Interaction message "EventRinging" generated
20:38:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
20:39:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
@20:40:51.8200 [0] 8.1.104.23 distribute_event: message EventRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA2:\'
20:20:54.821 Int 04544 Interaction message "EventNotRinging" generated
20:41:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0
@20:42:51.8200 [0] 8.1.104.23 distribute_event: message EventNotRinging
AttributeUserData [634] 00 18 00 00..
\'RTargetObjectSelected\' \'?VAG_EMERGENCIA1:\'
20:20:54.821 Int 04544 Interaction message "EventNotRinging" generated
20:42:51.821: $+SIP:CTI:HA_SEND_SYNC_MESSAGE:39982499:0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);