const regex = /"(.+?)"/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(.+?)"', 'gs')
const str = `fc = document.querySelectorAll('.forCode'); // это коллекция всех див блоков, в каждом из которых содержится код представленный в хтмл
let regObj = {
'console' : '<span style="color: red;">',
'isNaN' : '<span style="color: red;">',
'toFixed' : '<span style="color: red;">',
'Infinity' : '<span style="color: red;">',
'let' : '<span style="color: #7592c7;">',
'typeof' : '<span style="color: #7592c7;">',
'".+"' : '<span style="color: green;">', // ПОЧЕМУ не мэтчится?
};
for(let p in regObj){
for(let k=0; k<fc.length; k++){
fc[k].innerHTML = fc[k].innerHTML.replace(p, m => regObj[p]+m+'</span>');
};
};`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}