$re = '/^[a-zA-Z]{3,}$/m';
$str = 'how@@
ajhdjjbbx
fsdfsa2331f
Sdassfs
dd
d
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);