package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'[^']*(?:''[^']*)*'`)
var str = `The regex should capture this string: 'brown fox ''jumped ''''over the lazy dog'''.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}