re = /\b[0-9]{2}\.[0-9]{4}.*?(?=\b[0-9]{2}\.[0-9]{4}|$)/m
str = '24.3483 stuff stuff 34.8325 some more stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end