package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(@?\w+)(\W+)`)
var str = `this is a test of proper nouns @Ryan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}