$re = '/^[\w\-\d).]+\s/m';
$str = '<!-- Introduction avant le prétest -->
<!-- PARTIE 1 -->
<!-- Question 1 choix multiple -->
<p>Le 9 mai 2020, Sara a reçu un avis de cotisation pour l’année 2019. Comme elle partait en vacances le 1er août, elle a déposé un avis d’opposition à cette cotisation le 31 juillet 2020.</p>
<p>Vrai ou faux? Sara respecte ainsi les délais prévus par la Loi.</p>
- Vrai <!-- BONNE -->
- Faux
<!-- RÉTROACTION -->
<p>Vrai, car Sara n’a pas dépassé les 90 jours permis. Pour un particulier, le délai pour produire un avis d’opposition est, au plus tard, 90 jours suivant la date de la mise au courrier de l’avis de cotisation ou 1 an après la date limite de production de la déclaration des revenus.</p>
<p>Nous vous invitons à revoir la partie 1 du module Fiscalité.</p>
<!-- PARTIE 2 -->
<!-- Question 2 choix multiple -->
<p>Vrai ou faux? Pour un particulier né le 1er avril, son <strong>année d’imposition</strong> s’écoule du 1er avril au 31 mars, soit une période de 12 mois.</p>
- Vrai
- Faux <!-- BONNE -->
<!-- RÉTROACTION -->
<p>Pour un particulier, l’année d’imposition est l’année civile qui s’écoule <strong>du 1er janvier au 31 décembre</strong>.</p>
<p>Nous vous invitons à revoir la partie 2 du module Fiscalité.</p>
<!-- PARTIE 3 -->
<!-- Question 3 choix multiple -->
<p>Parmi les critères suivants, lequel est le moins pertinent lorsqu’il s’agit de distinguer l’employé du travailleur autonome? </p>
A) Le contrôle ou le lien de subordination
B) La propriété des instruments de travail
C) Le risque financier
D) Le pourcentage des heures de travail à domicile <!-- BONNE -->
<!-- RÉTROACTION -->
<p>Les 4 critères reconnus par l’ARC pour distinguer un employé et un travailleur autonome sont : le critère de <strong>contrôle</strong> (subordination), le critère de la <strong>réalité économique</strong>, le critère <strong>d’intégration</strong>, le critère du <strong>résultat spécifique</strong>.</p>
<p>Nous vous invitons à revoir la partie 3 du module Fiscalité.</p>
<!-- PARTIE 4 -->
<!-- Question 4 choix multiple -->
<p>
<p>Kevin s’est trouvé un nouvel emploi. Son nouvel employeur lui a versé une somme de 1 200 $ pour couvrir ses frais de déménagement. Kevin est bien content, car il a déménagé lui-même ses biens personnels et ses vêtements. Les frais réels de son déménagement sont bien en deçà de 1 200 $. Aux fins fiscales, il s’agit :</p>
</p>
A) D’un remboursement de dépenses
B) D’une allocation imposable <!-- BONNE -->
C) D’une allocation non imposable
D) Aucune de ces réponses
<!-- RÉTROACTION -->
<p>Un particulier doit <strong>ajouter</strong> à son revenu de charge ou d’emploi la valeur de la <strong>pension</strong>, du <strong>logement</strong> et <strong>autres avantages</strong> quelconques qu’il a reçus ou dont il a joui au cours de l’année.</p>
<p>Nous vous invitons à revoir la partie 4 du module Fiscalité.</p>
<!-- PARTIE 5 -->
<!-- Question 5 choix multiple -->
<p>Michel possède un immeuble de 6 appartements à Montréal. Il vit avec sa famille dans l’un de ces appartements et il loue les 5 autres. Les revenus de location gagnés par Michel constituent des :</p>
A) Revenus d’emploi
B) Revenus d’entreprise
C) Revenus de bien <!-- BONNE -->
D) Gains en capital
<!-- RÉTROACTION -->
<p>Un <strong>revenu de bien</strong> est un <strong>rendement sur le capital investi</strong> dans des biens meubles ou immeubles, corporels ou incorporels (ex. : revenu d’intérêts, de dividendes, de location, de redevances).</p>
<p>Nous vous invitons à revoir la partie 5 du module Fiscalité.</p>
<!-- PARTIE 6 -->
<!-- Question 6 choix multiple -->
<p>Vrai ou faux? Pour bénéficier de l’exemption prévue lors de la disposition d’une résidence principale, il faut que le vendeur soit un particulier résidant au Canada.</p>
- Vrai <!-- BONNE -->
- Faux
<!-- RÉTROACTION -->
<p>Pour bénéficier de l’exemption prévue lors de la disposition d’une résidence principale, certaines conditions s’appliquent, notamment, le vendeur doit résider au Canada. Autrement dit, un non-résident qui achète et revend une propriété la même année ne sera pas admissible à l’exemption.</p>
<p>Nous vous invitons à revoir la partie 6 du module Fiscalité.</p>
<!-- PARTIE 8 -->
<!-- Question 7 choix multiple -->
<p>Daniel a subi une perte en capital nette (PCN) de 10 000 $ en 2012. Pour les années 2013 à 2019, il n’a réalisé aucun gain ou perte en capital, alors qu’en 2020, il a réalisé un gain en capital net imposable de 6 000 $. </p>
<p>Vrai ou faux? Daniel peut reporter une partie de sa PCN de 2012 à 2020 pour faire en sorte qu’aucun impôt ne soit payable sur son gain en capital net réalisé.</p>
- Vrai <!-- BONNE -->
- Faux
<!-- RÉTROACTION -->
<p>Les pertes en capital nettes (PCN) sont reportables rétrospectivement sur les 3 années précédentes et indéfiniment sur les années futures.</p>
<p>Nous vous invitons à revoir la partie 8 du module Fiscalité.</p>
<!-- PARTIE 9 -->
<!-- Question 8 choix multiple -->
<p>Vrai ou faux? L’impôt à payer par un particulier est calculé en fonction de son <strong>revenu net</strong>.</p>
- Vrai
- Faux <!-- BONNE -->
<!-- RÉTROACTION -->
<p>L’impôt à payer par un particulier est calculé en fonction de son <strong>revenu imposable</strong>.</p>
<p>Nous vous invitons à revoir la partie 9 du module Fiscalité.</p>
<!-- PARTIE 10 -->
<!-- Question 9 choix multiple -->
<p>Vrai ou faux? Michel, ayant contribué à un régime enregistré d’épargne-études (REEE) au profit de ses enfants, sera imposé sur les revenus générés par les montants investis dans l’année où ses enfants retireront les sommes du régime.</p>
- Vrai
- Faux <!-- BONNE -->
<!-- RÉTROACTION -->
<p>Les <strong>revenus</strong> produits sont <strong>exonérés d’impôt</strong> jusqu’à ce qu’ils soient remis aux bénéficiaires. Les <strong>revenus</strong> sont alors <strong>imposables</strong> entre les mains des bénéficiaires.</p>
<p>Nous vous invitons à revoir la partie 10 du module Fiscalité.</p>
<!-- PARTIE 11 -->
<!-- Question 10 choix multiple -->
<p>Parmi les énoncés suivants sur les revenus d’entreprise gagnés par un particulier, indiquez celui qui est exact.</p>
A. Les salaires raisonnables versés aux différents membres de la famille (conjoint et enfants) sont déductibles du revenu de l’entreprise.
B. Les salaires versés aux différents membres de la famille (conjoint et enfants) ne sont pas déductibles du revenu de l’entreprise, même dans la mesure où ils sont raisonnables selon le travail effectué par ces personnes.
C. Les amendes et pénalités pour le non-respect des lois sont déductibles d’impôt.
D. Les pénalités de retard et les intérêts sur impôts sont déductibles d’impôt.
<!-- RÉTROACTION -->
<p>Nous vous invitons à revoir la partie 11 du module Fiscalité.</p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);