import re
regex = re.compile(r"^.*_(.*)\.txt$", flags=re.MULTILINE)
test_str = "UNKNOWN_{_requestID___b9b6bcc4-c163-45d7-82d9-423a96cf5fe1_,_deviceID___9c84f871-9e95-45d5-9335-12e7d42b96a0_}_2018-08-15-15-43-01-296_529307b7-6316-4cdc-ab53-2e1158c651c6.txt"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)