using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^# Match any youtube URL
(?:https?://)? # Optional scheme. Either http or https
(?:
www\.
| m\.
)? # Optional www subdomain
(?: # Group host alternatives
youtu\.be/ # Either youtu.be,
| youtube\.com # or youtube.com
(?: # Group path alternatives
/embed/ # Either /embed/
| /v/ # or /v/
| /&v=/ # or ?feature=youtu.be&v=NXwxHU2Q0bo
| /watch\?v= # or /watch\?v=
| /watch\?feature=youtu\.be&v= # alternativ link with watch
) # End path alternatives.
) # End host alternatives.
([\w-]{10,12}) # Allow 10-12 for 11 char youtube id.
$";
string input = @"https://www.youtube.com/watch?feature=youtu.be&v=NXwxHU2Q0bo";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}